[Fix] YouTube for Android: Tilkobling til Server mistet, berør for å prøve på nytt

Etter at jeg oppdaterte Xperia Z til siste Android Jelly Bean-versjon forrige måned begynte jeg ofte å få en feilmelding på YouTube-appen. Som vist på skjermdumpen nedenfor, lyste feilmeldingen, “Tilkobling til serveren mistet. Trykk for å prøve på nytt ”. Selv om jeg var sikker på at jeg var koblet til internett, skjedde ingenting selv etter å ha tappet på skjermen flere ganger. For å være sikker på at jeg var koblet til internett, åpnet jeg imidlertid Google Nyheter i nettleseren min, og jeg fikk den siste oppdateringen rett på skjermen. Til og med YouTube-appen klarte å søke etter videoer og laste inn kommentarer og forslag, men viste bare feilen mens du spilte videoen.








Forstå problemet

Siden jeg ikke var sikker på hva problemet kan være, søkte jeg etter det på noen populære Android-fora for å se om andre brukere møtte lignende problemer. Vel, det var mange som hevdet å ha det samme problemet, men det var ingen løsning i sikte. Det eneste jeg leste i de fleste innlegg var å starte telefonen på nytt og prøve på nytt, eller å trekke ut batteriet for å gjøre et resirkulering av strøm. Imidlertid fungerte ingen av de to rettelsene for meg, og jeg satt fast på den samme feilmeldingen.



Det var ikke slik at jeg var helt uten anelse om denne feilen. Takket være årene på ingeniørhøgskolen (ja, jeg endte opp med å studere i noen av dem), jeg visste at problemet på en eller annen måte var relatert til proxyinnstillingene til Android, og porten til appen som kobles til videoserveren ikke kunne å lage en forbindelse (ikke gå inn på den tekniske biten her).

Så etter noen timers feilsøking kunne jeg endelig spille av videoene på Android-en. Det er to sannsynlige løsninger på dette problemet, så la oss se på dem etter hverandre.





Deaktiver annonseblokkering

I den siste oppdateringen av Android-versjonen, hvis du har en annonse-blokkering aktivert på enheten din, påvirker det på en eller annen måte YouTube-appen. Appen blokkerer proxy-portene som YouTube kobler til for å hente videoen fra serveren. Så når du deaktiverer annonse-blokkeringen på Android-en din, vil du kunne spille av videoene på enheten din uten problemer. En enkel omstart kan være nødvendig for at innstillingene trer i kraft. Hvis du planlegger å avinstallere ad-blocker-appen, Husk å deaktivere innstillingene før avinstallering.

Imidlertid er løsningen ovenfor bare aktuelt hvis telefonen din er forankret og du bruker ad-blocker i den. I mitt tilfelle var telefonen min ikke forankret (ikke tillatt av bootloader).

Så jeg satt bare igjen med ett alternativ, og det var å sjekke Wi-Fi-avanserte innstillinger.





Deaktiver manuelle innstillinger for Wi-Fi

Den andre tingen du kan gjøre er å sjekke forskuddet innstillingene for Wi-Fi-tilkoblingen din. Hvis problemet er det jeg tror, ​​vil du se noen proxy-vertsnavn og proxy-port der inne under de manuelle innstillingene. Gå til innstillinger i din Android -> Wi-Fi -> langt trykk på nettverket du bruker, og det dukker opp en Endre nettverkskonfigurasjon alternativ. Da trenger du kanskje ikke å trykke på Vis avanserte innstillinger avhengig av hvilken telefon du bruker. Det vi trenger å se er statusen tilProxy-innstillinger og om det er det Ingen eller manual.

Alt du trenger å gjøre er å sikre at Proxy-innstillingene er satt som Ingen og ikke Manuell. Det er alt, det beste alternativet mitt er at du nå kan spille av videoene i YouTube-appen.





Fortsatt noe arbeid igjen

Fixet fungerte på de fleste enhetene jeg sjekket. Imidlertid går innstillingene i mitt tilfelle stadig tilbake og endres til manuell hver gang jeg kobler til et nytt Wi-Fi-nettverk. Jeg er ikke sikker på om noen andre har lignende problemer med telefonens Wi-Fi-avanserte innstillinger. Jeg har ennå ikke oppdaget en løsning for dette, så hvis du har noen løsning i tankene, kan du dele dem i kommentarene som alle kan se.